For Cisco ASR's or ISR's with Flexible Netflow:
Firstly, lets create an ACL for our Solarwinds Server:
ip access-list standard Solarwinds
permit host 192.168.0.55
!
Now we can enable SNMP:
snmp-server community tceo RO Solarwinds
snmp-server location Mario's Pizza Shop
snmp-server contact Mario Bros
Now to enable NetFlow:
flow record NETFLOW_RECORD
match ipv4 tos
match ipv4 protocol
match ipv4 source address
match ipv4 destination address
match transport source-port
match transport destination-port
match interface input
collect interface output
collect counter bytes
collect counter packets
!
flow exporter NETFLOW_EXPORT
destination 192.168.0.55
transport udp 2055
!
flow monitor NETFLOW_MONITOR
exporter NETFLOW_EXPORT
record NETFLOW_RECORD
Choose which interface to monitor traffic on for both ingress and egress. In this case I'm picking GigabitEthernet0/0/0
interface GigabitEthernet0/0/0
ip flow monitor NETFLOW_MONITOR input
ip flow monitor NETFLOW_MONITOR output
!
To check if all is working as expected, you can type the following command:
sh flow monitor
For Cisco ISR's without Flexible Netflow:
Firstly, lets create an ACL for our Solarwinds Server:
ip access-list standard Solarwinds
permit host 192.168.0.55
!
Now we can enable SNMP:
snmp-server community tceo RO Solarwinds
snmp-server location Mario's Pizza Shop
snmp-server contact Mario Bros
Now to enable NetFlow:
flow record NETFLOW_RECORD
match ipv4 tos
match ipv4 protocol
match ipv4 source address
match ipv4 destination address
match transport source-port
match transport destination-port
match interface input
collect interface output
collect counter bytes
collect counter packets
!
flow exporter NETFLOW_EXPORT
destination 192.168.0.55
transport udp 2055
!
flow monitor NETFLOW_MONITOR
exporter NETFLOW_EXPORT
record NETFLOW_RECORD
Choose which interface to monitor traffic on for both ingress and egress. In this case I'm picking GigabitEthernet0/0/0
interface GigabitEthernet0/0/0
ip flow monitor NETFLOW_MONITOR input
ip flow monitor NETFLOW_MONITOR output
ip flow monitor NETFLOW_MONITOR output
!
To check if all is working as expected, you can type the following command:
sh flow monitor
For Cisco ISR's without Flexible Netflow:
Firstly, lets create an ACL for our Solarwinds Server:
ip access-list standard Solarwinds
permit host 192.168.0.55
!
Now we can enable SNMP:
snmp-server community public RO Solarwinds
snmp-server location Marios Pizza Shop
snmp-server contact Mario Bros
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
Now to enable NetFlow:
ip flow-export version 9
ip flow-export destination 192.168.0.55 2055
Choose which interface to monitor traffic on for both ingress and egress. In this case I'm picking Gi0/0
interface GigabitEthernet0/0
ip flow ingress
ip flow egress
!
To check if all is working as expected, you can type the following command:
sh ip cache flow
If you just want to use Netflow without the export to a Netflow collector, just negate the "ip flow-export" commands.
For ASA Firewalls:
This process is a bit more complicated on a Cisco ASA firewall that the above Cisco configuration.
Firstly we name our Solarwinds Server:
name 192.168.0.55 Solarwinds
Enable SNMP:
snmp-server host dmz Solarwinds community public
snmp-server location Marios Pizza Shop
snmp-server contact Mario Bros
snmp-server community public
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
Now to enable Netflow - first we create an ACL for what traffic you wish to monitor - typically everything:
access-list netflow-export extended permit ip any any
Now we set the Netflow parameters:
flow-export destination <output interface name> Solarwinds 2055
flow-export template timeout-rate 3
flow-export delay flow-create 10
Configure our Netflow Classes:
class-map netflow-export-class
match access-list netflow-export
!
!
Configure our Policies:
policy-map global_policy
class netflow-export-class
flow-export event-type all destination Solarwinds
!
Great Article… I love to read your articles because your writing style is too good, its is very very helpful for all of us....
ReplyDeleteBest Training Institute in chennai
Hello,
ReplyDeleteIt was so nice article.I was really satisified by seeing this article and we are also giving SolarWinds online training
Thank you a lot for providing individuals with a very spectacular possibility to read critical reviews from this site.
ReplyDeletepython training in tambaram | python training in annanagar | python training in jayanagar
From your discussion I have understood that which will be better for me and which is easy to use. Really, I have liked your brilliant discussion. I will comThis is great helping material for every one visitor. You have done a great responsible person. i want to say thanks owner of this blog.
ReplyDeleteJava training in Marathahalli | Java training in Btm layout
Java training in Marathahalli | Java training in Btm layout
I have read a few of the articles on your website now, and I really like your style of blogging. I added it to my favourites blog site list and will be checking back soon.
ReplyDeleteData Science course in Indira nagar
Data Science course in marathahalli
Data Science Interview questions and answers
This is most informative and also this post most user friendly and super navigation to all posts... Thank you so much for giving this information to me..
ReplyDeletebest rpa training in chennai | rpa online training |
rpa training in chennai |
rpa training in bangalore
rpa training in pune
rpa training in marathahalli
rpa training in btm
I simply want to give you a huge thumbs up for the great info you have got here on this post.
ReplyDeleteangularjs Training in bangalore
angularjs interview questions and answers
angularjs Training in marathahalli
angularjs interview questions and answers
angularjs-Training in pune
Thanks for taking the time to discuss this, I feel strongly about it and love learning more on this topic.
ReplyDeleteangularjs Training in chennai
angularjs-Training in tambaram
angularjs-Training in sholinganallur
angularjs-Training in velachery
angularjs-Training in pune
I have been meaning to write something like this on my website and you have given me an idea. Cheers.
ReplyDeleteJava training in Bangalore | Java training in Jaya nagar
Java training in Bangalore | Java training in Electronic city
Java training in Chennai | Java training institute in Chennai | Java course in Chennai
Java training in USA
Awesome article. It is so detailed and well formatted that i enjoyed reading it as well as get some new information too.
ReplyDeleteBest Devops training in sholinganallur
Devops training in velachery
Devops training in annanagar
Devops training in tambaram
Hello! This is my first visit to your blog! We are a team of volunteers and starting a new initiative in a community in the same niche. Your blog provided us useful information to work on. You have done an outstanding job.
ReplyDeleteNo.1 AWS Training in Chennai | Amazon Web Services Training Institute in Chennai
AWS Online Training and Certification | Online AWS Certification Training Course
thank you for sharing this
ReplyDeleteBEST ANGULAR JS TRAINING IN CHENNAI WITH PLACEMENT
https://www.acte.in/angular-js-training-in-chennai
https://www.acte.in/angular-js-training-in-annanagar
https://www.acte.in/angular-js-training-in-omr
https://www.acte.in/angular-js-training-in-porur
https://www.acte.in/angular-js-training-in-tambaram
https://www.acte.in/angular-js-training-in-velachery
Thank you for sharing this unique information.
ReplyDeleteAngularJS training in chennai | AngularJS training in anna nagar | AngularJS training in omr | AngularJS training in porur | AngularJS training in tambaram | AngularJS training in velachery
Thanks a lot for sharing such a good source with all, i appreciate your efforts taken for the same. I found this worth sharing and must share this with all.
ReplyDeleteAngular js Training in Chennai
Angular js Training in Velachery
Angular js Training in Tambaram
Angular js Training in Porur
Angular js Training in Omr
Angular js Training in Annanagar
Awesome article. It is so detailed and well formatted that i enjoyed reading it as well as get some new information too.
ReplyDeleteIELTS Coaching in chennai
German Classes in Chennai
GRE Coaching Classes in Chennai
TOEFL Coaching in Chennai
Spoken english classes in chennai | Communication training
Nice blog.
ReplyDeleteCCNA course in Pune